こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Perl,PHPのインストール方法

Perl,PHPのインストール方法が解らなくなりました。

1度はできたと思ったのですが、解らなくなりました。

OSはUBUNTU17.04です。

いつも教わってばかりですみません。

ご回答のほど宜しくお願い申し上げます。

投稿日時 - 2017-10-28 02:27:54

QNo.9390763

困ってます

質問者が選んだベストアンサー

$ sudo apt-get install lamp-server

apt-get ではなくて tasksel です。

$ sudo tasksel install lamp-server

投稿日時 - 2017-10-28 23:33:24

お礼

ご回答誠にありがとうございました。

投稿日時 - 2017-11-20 02:49:24

ANo.3

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

>Perl,PHPのインストール方法が解らなくなりました。
>OSはUBUNTU17.04です。
そのOSにはPerlが標準で組み込まれていますので、インストールする必要はありません。
PHPはスーパーユーザーでaptのinstallオプションを使えばインストールできます。
sudo apt install php
sudo(スーパーユーザーでコマンド実行を宣言)には管理者アカウントのパスワードの入力が必要です。
インストールの途中でディスクの消費容量が通知され、続行の要否(Y/n)を問われますのでyを入力すれば続行してインストールが完了します。

投稿日時 - 2017-10-28 13:21:55

お礼

ご回答誠に有難うございます。

また色々と教えてください。

投稿日時 - 2017-11-20 03:18:34

ANo.1

過去の質問を読むと、Linux初心者でPerlやPHPを使いたいということですので、用途はホームページの開発環境を整えたいという目的でしょうか?

であれば、LAMP環境を一括でインストールできるtaskselを使うと楽です。
ちなみにLAMPとは、LinuxOSでHTTPサーバのApache、DBのMySQL、プログラミングのPerl・PHP・Pythonが動く環境を云います。

Ubuntuであればターミナルを起動して、sudo権限 で tasksel コマンドを叩けば一括インストールできます。

詳しくは次のURLをご覧ください。
https://qiita.com/HirofumiYashima/items/a0291f018768118dc1cc

また、初心者だとインストール後の設定の点でも苦労すると思います。
それに備えてWebminもインストールしておくと良いでしょう。

Webminのインストールは、ターミナルを起動して次のようにコマンドを入力します。
$ sudo gedit /etc/apt/sources.list.d/webmin.list

geditが起動したら、次の一行(リポジトリ)を追加し、geditを保存終了します。
deb http://download.webmin.com/download/repository sarge contrib

再度ターミナルに戻り次のコマンドを入力します。
$ sudo wget http://www.webmin.com/jcameron-key.asc
$ sudo apt-key add jcameron-key.asc
$ sudo apt update -y
$ sudo apt install -y webmin

以上でWebminのインストールは完了です。
ブラウザを起動して、 https://localhost:10000 にアクセスするとWebminの管理画面に入れます。

以降は、次のページの「2 WEBINへアクセス」の項目をご覧ください。
https://www.hiroom2.com/2017/01/14/ubuntu-16-04-webmin%E3%82%92%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%E3%81%99%E3%82%8B/

Webminの使い方説明は余りにも多岐に渡るので、ここでは省略します。
「Webmin 使い方」等のキーワードで検索してください。

なお、Webminはログインさえ通れば、サーバ周りの設定を何でも出来てしまうので、セキュリティ周りの設定をしっかりしないとかなり危険です。
初めのうちはローカルの開発環境を設定する目的で利用するようにしましょう。

投稿日時 - 2017-10-28 09:22:27

お礼

ご回答誠にありがとうございます。

$ sudo apt-get install lamp-server
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
E: パッケージ lamp-server が見つかりません

と出ました。

どこかおかしいのでしょうか?

投稿日時 - 2017-10-28 19:45:17